Performance degradation at German Customs

Incident Report for Riege Software

Resolved

This incident has been resolved.
Posted May 07, 2026 - 06:10 UTC

Investigating

German Customs has unreported performance degradation,
that is why there are currently delays
We have requested further information from Customs
Posted May 05, 2026 - 08:32 UTC
This incident affected: Customs (🇩🇪 Germany).