Performance degradation at German Customs NCTS only

Incident Report for Riege Software

Update

We are continuing to work on a fix for this issue.
Posted Sep 01, 2026 - 09:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 01, 2026 - 09:02 UTC

Investigating

German Customs has performance degradation.
Affected procedures: NCTS
Masterticket: INC000007451925
Posted Sep 01, 2026 - 09:02 UTC
This incident affects: Customs (🇩🇪 Germany).