Performance degradation at German and Swiss Customs

Incident Report for Riege Software

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 08:04 UTC

Investigating

Customs has performance degradation.
Affected procedures: all
Masterticket: is following
Posted Oct 23, 2025 - 07:07 UTC
This incident affected: Customs (🇩🇪 Germany).